Receiving Java Install Did Not Complete Error while Installing Test Data Manager

Document ID : KB000005800
Last Modified Date : 14/02/2018
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Issue:

While running the Test Data Manager installation wizard, it is trying to install Java as a prerequisite. However, the installation does not finish and I receive the following error message: JAVA INSTALL DID NOT COMPLETE - Error Code : 1603. I already have a Java version installed. I am installing Java to the default location on the C drive.

Environment:
CA Test Data Manager (TDM), Java
Cause:

This error means that the installation of the new Java version did not complete. The root cause of the error is still under investigation by Java. You can read more about the issue here: https://java.com/en/download/help/error_1603.xml 

 

System Administrator access is required for the TDM installation. If you do not have this access, it may be the cause of this error message.

Resolution:

There are two available resolutions for this issue. They are outlined in this document https://java.com/en/download/help/error_1603.xml and below.

 

Option 1:

  1. Uninstall all existing Java versions from your machine. 
  2. Restart your machine.
  3. Download Java's offline installer package: https://java.com/en/download/windows_offline.jsp 
  4. Double click on the installation file you just downloaded to start the installation process.
  5. Follow the prompts until the installation is complete.
  6. Try to re-install Test Data Manager by running the installation wizard.

 

Option 2:

  1. Locate and launch your Java Control Panel. 
  2. Click on the 'Security' tab in the Java Control Panel.
  3. Uncheck the 'Enable Java content in the browser' option.
  4. Click the 'Apply' button.
  5. Click the 'OK' button to confirm and save all changes.
  6. Download Java's offline installer package: https://java.com/en/download/windows_offline.jsp 
  7. Double click on the installation file you just downloaded to start the installation process.
  8. Follow the prompts until the installation is complete.
  9. Go back to the Java Control Panel.
  10. Click on the 'Security' tab.
  11. Check the box for the 'Enable Java content in the browser' option. 
  12. Try to re-install Test Data Manager by running the installation wizard.
Additional Information:

If you experience any further issues, please open a support case on https://support.ca.com/irj/portal/newhome or call support at one of these numbers https://www.ca.com/us/services-support/ca-support/contact-support.html.