Receiving error message DFS0749I and abend code U2990 reason 96A0C020.

Document ID : KB000004083
Last Modified Date : 14/02/2018
Show Technical Document Details
Issue:

After upgrading IMS, error message DFS0749I is occurring when accessing data which requires compression routine services.

DFS0749I COMPRESSION EXIT ROUTINE nnnnnnnn INITIALIZATION ERROR – U2990 REASON 96A0C020 

This problem did not occur prior to the upgrade of IMS.

Environment:
IMS version upgrade.
Cause:

Having upgraded IMS, the IMS RESLIB did not contain the CA Compress for IMS, IMS version specific modules, required to support the new version of IMS. This resulted in the U2990 IMS user abend, as CA Compress for IMS was not able to access the necessary version specific modules for this version of IMS.

 

Resolution:

The Compress for IMS modules are provided to support the currently available IMS versions: so release r19 supports IMS v12, v13 and v14. Stub modules will call the relevant IMS version specific modules. For example, the IMSHRINK stub calls 1 of 3 modules dependent on the version of IMS:

IMSHRNKK

IMSHRNKL

IMSHRNKM

 

The 1 letter suffix identifies the IMS version supported by that release. The suffixing we use for these version specific modules is as follows:

IMS version        Module suffix

v12                                      K

v13                                      L            

v14                                      M

 

Note there is no requirement to reassemble any modules when upgrading IMS. However, if the CA Compress for IMS modules have been copied from the distributed CIMTLOAD to another library, such as the IMS RESLIB, then you need to ensure that all the required modules are copied.

 

Additional Information:

Refer to the following r19 Techdoc which lists all the required modules by name.

http://www.ca.com/us/services-support/ca-support/ca-support-online/knowledge-base-articles.tec1585292.html