RDM fails to retrieve data for display in the iConsole

Document ID : KB000124337
Last Modified Date : 10/01/2019
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Issue:
The CA Data Protection Remote Data Manager (RDM) is unable to retrieve data from a mail archive (for example Symantec Enterprise Vault) in a timely fashion, this  results in failed iConsole Searches.  The iConsole logs record errors similar to the one below:

Dec 24, 2018 18:06:06.352 <user> E19FF TID:0x0000298c An unexpected Exception was thrown: "Thread was being aborted." at idata.CEvent.Cache(CEvent* , CWgnLogFile* , IWgnSession* , Boolean , CErrorInfo* , Boolean ) at WgnWebEventData.CWgnWebEventData.CanAccessEventID(String pSessionID, IWgnSession* pSession, Int64 idEventUID, Int64 tsEvent, CErrorInfo* Err, Int32* pbGranted) at WgnWebEventData.CWgnWebEventData.CanAccessEvent2(String pSessionID, String pEventID, String pSearchID, Boolean& pbGranted, EventType& ppEventType) InnerException: 

 
Environment:
CA Data Protection 15.x with RDM installed.
Cause:
In some busy network environments where there is congestion or where extremely large files need to be retrieved the default retrieval time of 5 Minutes may not be suffcient for the task to complete successfully.
Resolution:
The solution to this issue is to increase the maximum period of time that CA Data Protection will allow for the RDM to fetch a file from the archive.

This is configured via the 'GlobalFileRetrieveTimeoutMilliseconds' registry setting on the RDM machines.

Add the registry key 'GlobalFileRetrieveTimeoutMilliseconds' on the RDM machines under the key

HKEY_LOCAL_MACHINE\SOFTWARE\ComputerAssociates\CA DataMinder\CurrentVersion\Remote Data Manager

and set the REG_DWORD value to 420,000 (equivalent to 7 minutes).

Please refer to the documentation (link below) for further guidance.

https://docops.ca.com/ca-data-protection/15-2/en/integrating/archives/remote-data-manager/rdm-post-installation-tasks

 
Additional Information:
Orchestria, Orchestria EMP, Orchestria APM, CADLP and CA DataMinder are all previous brands for the product now known as CA Data Protection.

CA is a Broadcom company.