RA OEBS Agent not starting

Document ID : KB000087566
Last Modified Date : 14/04/2018
Show Technical Document Details
Issue:
Error Message :
Connection object does not exist for xmlName: connection

RA OEBS Agent won't start. A force trace file is created with the following errors: 

java.lang.RuntimeException: Connection object does not exist for xmlName: connection
at com.uc4.extensibility.objs.ConnectionsData.getConnectionData(ConnectionsData.java:61)
at com.uc4.extensibility.objs.ConnectionsData$getConnectionData.call(Unknown Sou

 
This error can be displayed if no Connection object has been defined for the RA OEBS Agent.

References

Documentation for creating OEBS CONN object:
 
 
Cause:
Cause type:
Configuration
Root Cause: RA OEBS Agent is missing a Connection object
Resolution:
This field was added on 30/03/2017. This article has not been updated yet. Refer to the "Description" or "Workaround" sections for solution information.

Fix Status: No Fix

Additional Information:
Workaround :
In Client 0:1) Create a Connection Object for OEBS 2) Edit OEBS Agent 3) On "Oracle E-Business Suite" tab, assign the Connection object4) Save, and start OEBS Agent