Question about setting the session timeout value for CA Automation Point's Notification Manager Website

Document ID : KB000046517
Last Modified Date : 14/02/2018
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Issue:

I have noticed that the Notification Manager website application sometimes times out after only a few minutes of inactivity in the browser. We have checked the web.xml file for the Apache Tomcat 7 server, and the session timeout value is set to 30 minutes. What can I change in the configuration so that it can remain idle for a longer period of time without timing out?

Environment:

Any Supported Microsoft Windows client or server operating system and Web Browser

Cause:

The root cause of the issue is likely that your browser is losing session cookie information. This causes the browser to lose its link reference to the HTTP session object on the server, so whenever your application remains idle for too long, a new HTTP session object must be created which does not have any login information (so then you are forced to re-login)

Resolution:

What you can do to mitigate this issue is block all cookies in your web browser. With cookies blocked in the web browser client, as per the design of the Notification Manager website application, the server will then pass the value of the HTTP session reference object as an HTTP request parameter by a technique called URL Rewriting. This way the link between the HTTP request and the previously established HTTP session object will remain preserved, for up to 30 minutes of inactivity in your IE 11 browser session, so that when you use the NM Website after logging in and then a long period of inactivity, you will no longer need to re-login.