QoS Metrics From Certain Probes do not Show in USM

Document ID : KB000047902
Last Modified Date : 14/02/2018
Show Technical Document Details

Symptoms


Symptom:

QoS metrics from certain probes do not show in USM. When you look at the Metrics Tab of the device within USM, you can see graphs for the different QoS metrics being collected, but when expanding System --> Performance --> WinNT (for ntperf/ntperf64), no graphs show and all you see is "Retrieving data..."

Notes
  • Issue was found in UMP version 6.5
  • List of probes that could be affected:
    • snmptd
    • ntevl
    • dirscan
    • ad_response
    • ntservices
    • ntperf
    • ...and there may be others.









Solution


Solution:

Engineering found that this occurs if the unit_short column in the S_QOS_DEFINITION table does not contain any value, not even an "empty string". A defect has been filed to have this resolved in a future release of UMP but there is a workaround to get this working immediately.?

The idea is to set the unit_short column to contain a single space. This "tricks" USM into thinking there is something there and then it works. First deactivate the wasp probe. Then you can run this query to change the blank/nulls to an empty space by running this query:

update S_QOS_DEFINITION set unit_short = ' ' where unit_short = '' ;

IMPORTANT NOTE REGARDING QUERY
(The first ' ' is a single quote followed by a space followed by a single quote, and then at the end it's two single quotes without a space in between: '' (not a double-quote mark.))

Activate the wasp probe after the query has been run and verify that the Metrics are available.

NOTES
  • If new QOS DEFINITIONS are created and its unit_short column is blank, the query will need to be run again otherwise you will have the same issues for the newly added metric(s).
  • List of probes that could be affected (unit_short column is blank):
    • snmptd
    • ntevl
    • dirscan
    • ad_response
    • ntservices
    • ntperf
    • ...and there may be others.