Custom Jasper report is not working after upgraded

Document ID : KB000097843
Last Modified Date : 12/06/2018
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Issue:
A single custom report is not working after upgrading the environment. Other customer reprots are running fine. OOTB reports are running successfully also.

Error Message:

Error Details The server has encountered an error. Please excuse the inconvenience.

Error Message An error has occurred. Please contact your system administrator. (6632)
Cause:
Found this error in the Jasperserver.log file:

com.jaspersoft.jasperserver.api.JSSecurityException: An error has occurred. Please contact your system administrator. (6632) at com.jaspersoft.jasperserver.api.security.validators.ValidatorImpl.validateSQL(ValidatorImpl.java:394) As per the following webpage, this likely indicates invalid underlying SQL queries: https://laurenthinoul.com/how-to-fix-jasperserver-error-6632/

As per the following webpage, this likely indicates invalid underlying SQL queries: 

https://laurenthinoul.com/how-to-fix-jasperserver-error-6632/ 

The customer was advised to edit the report in Studio and fix the validation error. He discovered that the semicolon character, ';', is not allowed in report queries. 

Research on TIBCO's community forum, we discovered that the semicolon is forbidden in queries by an input validation rule on the server with intent to prevent malicious attacks against the server to exfiltrate data: 

https://community.jaspersoft.com/documentation/tibco-jasperreports-server-security-guide/v630/configuring-input-validation#top
Resolution:
The report developer was advised to edit the customer report in Studio and fix the SQL validation error by replacing the ';' character with a comma character ','. The developer was then able to validate and run the report successfully.