Public change statuses are displayed in drop down despite data partition

Document ID : KB000006288
Last Modified Date : 14/02/2018
Show Technical Document Details
Issue:

Data partition set to display, for a Change Order, only the initial status and the statuses related to a specific tenant doesn't work and also the 'public' statuses are displayed in the dropdown 

Environment:
CA Service Desk Manager 14.1
Cause:

Problem due to 'lookup=no' set in the customized 'order_status_change.htmpl' file, to force the display of a dropdown instead of a lookup.

Original content of order_status_change.htmpl file:

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<PDM_MACRO name=dtlDropdown hdr="New Status" attr=status default="!default_trans_sym!" evt="onBlur=\\\"detailSyncEditForms(this)\\\" onChange=\\\"make_desc_required(this)\\\"" initial="!default_trans_code!">

---------- 

With customization in place:

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<PDM_MACRO name=dtlDropdown hdr="New Status" attr=status lookup=no default="!default_trans_sym!" evt="onBlur=\\\"detailSyncEditForms(this)\\\" onChange=\\\"make_desc_required(this)\\\"" initial="!default_trans_code!">

-------------------- 

 

Resolution:

Using the default file or after removing the 'lookup=no' statement from the customized file, the statuses displayed are the correct ones, on the base of the data partition set.

Note:

To have a dropdown instead of a lookup, there is the possibility to act on the parameters MaxSelectList and SelListCacheMax inside the web.cfg file.