Proxy manager is not loading on a new server.

Document ID : KB000004128
Last Modified Date : 14/02/2018
Show Technical Document Details
Issue:

We have installed a new server and the proxy manager is not loading.

Following are the error messages it provides. How could we fix it?

2016-04-05 09:00:12.296 | ERROR | main | com.ca.ppm.proxymanager.ProxyManager :36 | Failed to load ProxyManager service:
java.lang.RuntimeException: JBOSS_HOME property was not set
at com.ca.ppm.springAppCore.jms.PropertyPlaceholderConfigurerOverride.convertProperties(PropertyPlaceholderConfigurerOverride.java:33) ~[springAppCommon-0.1-SNAPSHOT.jar:?]
at org.springframework.beans.factory.config.PropertyResourceConfigurer.postProcessBeanFactory(PropertyResourceConfigurer.java:83) ~[spring-beans-4.1.2.RELEASE.jar:4.1.2.RELEASE]
at org.springframework.context.support.PostProcessorRegistrationDelegate.invokeBeanFactoryPostProcessors(PostProcessorRegistrationDelegate.java:265) ~[spring-context-4.1.2.RELEASE.jar:4.1.2.RELEASE]

Cause:

This could happen if the JAVA_HOME is not properly set for ProxyManager. Need to set JAVA_HOME in the ProxyManager's properties file correctly. Please follow the following steps.

Resolution:

Go to the ProxyManager directory and open the properties file for editing.

# cd /opt/CA/AccessControlServer/Services/ProxyManager/conf/
# vi proxymanager.properties

2- In proxymanager.properties, set JAVA_HOME.

As a reference, this is what I have JAVA_HOME set to in my lab.
# Location of the recording files in the file system
recording_files_folder=/var/log/samproxy
JBOSS_HOME=//opt//jboss-4.2.3.GA
SERVER_MODE=true
TOMCAT_HOME=/opt/CA/AccessControlServer/apache-tomcat-7.0.54

3- Save the file and recycle services via pimctl.sh and check.

    ProxyManager  should be working now

Additional Information:

On Windows a similar issue has been observed for the CA ControlMinder Event Forwarder Service and the ProxyManager.

Both services basically fail to startup showing the above error in the respective log when ENTM r12.9x is not installed in the default folder location.

 

In this case open a case with CA Support and request a make-up script (T6CI013) correcting the missing settings

To fix the issue with the  EventForwarder only edit the following files setting the values accordingly

E:\Program Files\CA\AccessControlServer\Services\EventForwarder\conf\config.properties
######################################################################################################
#Supported values: S (seconds) M (minutes) H (hours) i.e. 30:M = 30 minutes.
STATISTIC_SLEEP_TIME=5:M
# When TEST_MODE is true, send events configuration is handle in the test_events_log4j2.xml (ENTM UI configuration is ignored )
TEST_MODE=false
JAVA_HOME=E:\\jdk1.8.0
JBOSS_HOME=E:\\jboss-4.2.3.GA
######################################################################################################

This issue is not occurring in CA PIM r14.