Production down recovery: Automic Server processes are down and not able to start.

Document ID : KB000089493
Last Modified Date : 14/04/2018
Show Technical Document Details
Issue:
Production down recovery: Automic Server processes are down and not able to start.
Resolution:

Symptoms

  • Production down no jobs are being processed.
  • Communication (CP)  and Working Processes (WP) are down.
  • No logon to Automic possible.
  • Restart of Server Processes fail.


Investigation

Data needed for analysis:

  • All Serverlogfile (CP and WP) from the time the error occurred +/- half an hour.
  • Serverlogfile that capture the failed restarts.

The following error message can be found in the Working Processes log file:

SQL_ERROR    Database handles  DB-HENV: 3d9200  DB-HDBC: 3d92c0
U0003591 DB error info: Opc: 'SQLDriverConnect' Return code: 'ERROR'
U0003592 Status: '28000' Native error: '18456' Msg: 'Login failed for user 'Automic'.'
U0003592 Status: '42000' Native error: '4060' Msg: 'Cannot open database "Automic" requested by the login. The login failed.'
U0003590 DB error: 'SQLDriverConnect', 'ERROR   ', '42000', 'Cannot

The error message "U0003592 Status: '42000' Native error: '4060' Msg: 'Cannot open database "Automic" requested by the login. The login failed." is returned by the database when Automic tries to logon.

Cause

The password set in the connection string in the UCSRV.ini ODBC section (default location in Automation Engine/bin) is not valid.

Automic receives the error message that the login has failed from the database and no connection to the database is possible.


Resolution

  • Open the UCSRV.ini (default location in Automation Engine/temp folder)
  • Edit the connection string in the ODBC section and enter the correct password in the section "PWD="
  • Save changes to the UCSRV.ini
  • Restart Server Processes