Process Automation: Can I use JDK 1.8.0_xx with Process Auto 4.2?

Document ID : KB000011394
Last Modified Date : 14/02/2018
Show Technical Document Details
Question:

Can I use JDK 1.8.0_xx with Process Automation 4.2?

Answer:

Version 4.2 was tested and certified with JDK versions 1.7.0_80 and earlier.

Some Companies allow Oracle Java to automatically upgrade the system JDK.  Once JDK 1.8.0_xx is downloaded and installed Process Automation stops working with version 4.2.x. 

Process Automation version 4.3 is certified with JDK 1.8.0_xx.

 


If using Process Automation 4.2 you will need to use JDK 1.7.0 prior to version 80 .  If your company requires JDK 1.8.0 you will need to upgrade to Process Automation version 4.3.x.

 

Please note - This also applies to the non-public JDK 7 releases, versions 1.7.0_81 or later.