Problem with Integration Step USS in Migration

Document ID : KB000105881
Last Modified Date : 25/09/2018
Show Technical Document Details
Issue:
The setup process is failing during the integrating products phase. 

2018/07/08 01.48.39.911 DEBUG [DeployThread: Integrating the Product(s)] [ConfigureOSOPWithSDM] OSOP_SDM_IS_INTEGRATED : false OSOP_HOSTNAME (USS_SERVER_HOSTNAME) SDM_HOSTNAME (USS_SERVER_HOSTNAME) isOSOPIntegSkipEnabled :(true)
2018/07/08 01.48.39.912 DEBUG [DeployThread: Integrating the Product(s)] [ConfigureOSOPWithSDM] Validating OSOP User Login (CASMAdmin) URL: (http://USS_SERVER_HOSTNAME:8686/rest/session) 
2018/07/08 01.48.39.961 ERROR [DeployThread: Integrating the Product(s)] [ConfigureOSOPWithSDM] Unable to login into Unified Self-Service on server: USS_SERVER_HOSTNAME
2018/07/08 01.48.39.962 DEBUG [DeployThread: Integrating the Product(s)] [ConfigureOSOPWithSDM] Not Found 
2018/07/08 01.48.39.972 ERROR [DeployThread: Integrating the Product(s)] [ConfigureOSOPWithSDM] Unable get CA Service Desk Manager configuration details on Unified Self-Service on server: USS_SERVER_HOSTNAME
2018/07/08 01.48.39.972 DEBUG [DeployThread: Integrating the Product(s)] [ConfigureOSOPWithSDM] Not Found 
2018/07/08 01.48.39.972 INFO [DeployThread: Integrating the Product(s)] [ConfigureOSOPWithSDM] Was Unified Self-Service integrated with CA Service Desk Manager earlier : false 
2018/07/08 01.48.39.972 DEBUG [DeployThread: Integrating the Product(s)] [ConfigureOSOPWithSDM] Execution of integration task (com.ca.smsi.installui.integration.tasks.ConfigureOSOPWithSDM) is false 
2018/07/08 01.48.39.972 DEBUG [DeployThread: Integrating the Product(s)] [AutoIntegrateTask] Executing auto-integration task : Class <com.ca.smsi.installui.integration.tasks.ConfigureOSOPWithSDM> . Integration isAllowed : false 
2018/07/08 01.48.39.995 DEBUG [DeployThread: Integrating the Product(s)] [ConfigureOSOPWithSLCM] OSOP_SLCM_IS_INTEGRATED : false SLCM_HOSTNAME (SLCM_SERVER_HOSTNAME) osopHostname :(USS_SERVER_HOSTNAME) isOSOPIntegSkipEnabled :(true) 
2018/07/08 01.48.39.995 DEBUG [DeployThread: Integrating the Product(s)] [ConfigureOSOPWithSLCM] Validating OSOP User Login (CASMAdmin) URL: (http://USS_SERVER_HOSTNAME:8686/rest/session) 
2018/07/08 01.48.40.042 ERROR [DeployThread: Integrating the Product(s)] [ConfigureOSOPWithSLCM] Unable to login into Unified Self-Service on server: USS_SERVER_HOSTNAME
2018/07/08 01.48.40.042 DEBUG [DeployThread: Integrating the Product(s)] [ConfigureOSOPWithSLCM] Not Found 
2018/07/08 01.48.40.055 ERROR [DeployThread: Integrating the Product(s)] [ConfigureOSOPWithSLCM] Unable get CA Service Catalog configuration details on Unified Self-Service on server: USS_SERVER_HOSTNAME
2018/07/08 01.48.40.056 DEBUG [DeployThread: Integrating the Product(s)] [ConfigureOSOPWithSLCM] Not Found 
2018/07/08 01.48.40.056 INFO [DeployThread: Integrating the Product(s)] [ConfigureOSOPWithSLCM] Was Unified Self-Service integrated with CA Service Catalog earlier : false 
2018/07/08 01.48.40.056 DEBUG [DeployThread: Integrating the Product(s)] [ConfigureOSOPWithSLCM] Execution of integration task (com.ca.smsi.installui.integration.tasks.ConfigureOSOPWithSLCM) is false 
Environment:
CA Service Management 17.1
OS: Windows 2012
Cause:
Missing entries in al_cdb_configurationparameters table

Undetermined why it was missing in first place.
Resolution:
Insert the following entries al_cdb_configurationparameters table from DB:

Note**: Ignore inserting the entries that already exist in Database with below configkey

For SQL Server:

1) insert al_cdb_configurationparameters(componentkey,machinename,configkey,configvalue,productcode, last_update_date) values('itsm','common','osop.eem.is.integrated','1',9,'1508335080807')
2) insert al_cdb_configurationparameters(componentkey,machinename,configkey,configvalue,productcode, last_update_date) values('itsm','common','osop.sdm.is.integrated','1',9,'1508335080807')
3) insert al_cdb_configurationparameters(componentkey,machinename,configkey,configvalue,productcode, last_update_date) values('itsm','common','osop.slcm.is.integrated','1',9,'1508335080807')

For Oracle Database:

1) insert into al_cdb_configurationparameters(componentkey,machinename,configkey,configvalue,productcode, last_update_date) values('itsm','common','osop.eem.is.integrated','1',9,'1508335080807')
2) insert into al_cdb_configurationparameters(componentkey,machinename,configkey,configvalue,productcode, last_update_date) values('itsm','common','osop.sdm.is.integrated','1',9,'1508335080807')
3) insert into al_cdb_configurationparameters(componentkey,machinename,configkey,configvalue,productcode, last_update_date) values('itsm','common','osop.slcm.is.integrated','1',9,'1508335080807')

Restart the installation/ upgrade process again. 
 
Additional Information:
If Installation/ upgrade fails from the ISO directly, Extract the contents on to local server and re-ran the installation.