Problem when importing metadata containing multiple Attribute Services

Document ID : KB000006275
Last Modified Date : 14/02/2018
Show Technical Document Details
Issue:

When importing metadata containing mulitple Attribute Services, I see only the first one is imported and the other ones aren't imported. 

 

For example :

<?xml version="1.0" encoding="UTF-8"?>

<EntityDescriptor xmlns="urn:oasis:names:tc:SAML:2.0:metadata" xmlns:ds="http://www.w3.org/2000/09/xmldsig#" xmlns:shibmd="urn:mace:shibboleth:metadata:1.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" entityID="https://entity.ca.com/idp/shibboleth">

<IDPSSODescriptor>

<SingleSignOnService Binding="urn:mace:shibboleth:1.0:profiles:AuthnRequest" Location="https://entity.ca.com/idp/profile/Shibboleth/SSO"/>

<SingleSignOnService Binding="urn:oasis:names:tc:SAML:2.0:bindings:HTTP-POST" Location="https://entity.ca.com/idp/profile/SAML2/POST/SSO"/>

<SingleSignOnService Binding="urn:oasis:names:tc:SAML:2.0:bindings:HTTP-POST-SimpleSign" Location="https://entity.ca.com/idp/profile/SAML2/POST-SimpleSign/SSO"/>

<SingleSignOnService Binding="urn:oasis:names:tc:SAML:2.0:bindings:HTTP-Redirect" Location="https://entity.ca.com/idp/profile/SAML2/Redirect/SSO"/>

</IDPSSODescriptor>

</EntityDescriptor>

 

When I check the Entity in the AdminUI, I see only the first SingleSignOnService is imported:

<SingleSignOnService Binding="urn:mace:shibboleth:1.0:profiles:AuthnRequest" Location="https://entity.ca.com/idp/profile/Shibboleth/SSO"/>

 

Environment:
PS /AdminUI 12.52SP1CR06 on LinuxPstore : Oracle RDBMS
Resolution:

A devfix has been provided for this issue by our Sustaining Engineering.

It will be available in the next Policy Server release : 12.52SP1CR07