Problem to see session recordings after upgrade to 3.1.1

Document ID : KB000074440
Last Modified Date : 21/03/2018
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Issue:
Customers are having problems to open the session records from older version (3.0.2.05 or earlier) after doing the upgrade to the 3.1.1.

Viewing session recordings from older versions fails with the following message:
PAM-CMN-3333: Current session recording file '<session recording file name>.gsr' is broken or refers to other CA PAM.
 
Environment:
CA PAM 3.0.2 or earlier upgraded to 3.1.1
Cause:
CA PAM introduced encryption for the Session Recording files. Due to this implementation, the component responsible for replaying session recordings were expecting exclusively encrypted files.
Resolution:
Engineering provided a fix to this issue, so the playback component detects if the file is encrypted or not and proceed accordingly. It is not a common patch, it has to be manually deployed via SSH.

Customers that see themselves in this situation should open a ticket on CA Support asking for the fix from DE346215.

Note: This fix will be formally available on CA PAM 3.1.2, 3.2, 3.0.3 and above.