Problem runnig pdm_k_reindex command

Document ID : KB000009012
Last Modified Date : 14/02/2018
Show Technical Document Details
Issue:

Command pdm_k_reindex not working.

In the ebr_reindex.log file we can see following errors:

 pdm_k_reindex 27799 ERROR FileMng.c 1679 GetFileSize() - Unable to get file size of /opt/unitCASDM/KT/EBR/dic.ebr (Valor demasiado grande para el tipo de datos definido (75))
pdm_k_reindex 27799 ERROR EBRFileIndex.c 1352 IndexWordDic() - Failed to get size of /opt/unidadCASDM/KT/EBR/dic.ebr.

 

Note :  (Valor demasiado grande para el tipo de datos definido (75)) translation (Value too big for the defined data type 875))

 

Environment:
ServiceDesk 14.1 Advanced Availability setupLinux environment
Cause:

The cause was related to the shared location for the index files (.ebr files) needed by the Search Engine.

Resolution:

In an Advanced Availability setup, in order to allow the Background and the Standby server to access the .ebr files, these files are in a shared location.
After mount the shared location with NFS mounts instead of UNC mounts , the problem and errors reported get fixed.

 

Regarding this, note following point in the documentation, section "Considerations for Advanced Availability Configuration":

"You require a remote database server and a server to share knowledge Management index files and import/export files, archive purge output files, and attachment repositories. To allow the background and the standby server to access these files, a shared location is required. Linux and Unix installations can use NFS mounts. UNC support has been added for Windows installations."

Additional Information:

https://docops.ca.com/ca-service-management/14-1/en/implementing/implementing-ca-service-management-14-1/step-4-install-or-upgrade/implementing-ca-service-desk-manager/how-to-install-ca-sdm/step-1-plan-your-ca-sdm-installation/installation-considerations