Problem installing the 12.1 Eclipse Plug-in into the RAD 7.0 environment.

Document ID : KB000051374
Last Modified Date : 14/02/2018
Show Technical Document Details

Description:

When trying to install the SCM 12.1 Eclipse Plug-In to the RAD 7.0 environment we get the following error:

"CA SCM Team Provider (12.1.0.025) requires plug-in "org.eclipse.zest.core (1.1.0)", or later version.

Solution:

You can find more details about this error message in the release notes for SCM 12.1. Checking p. 41 under "Eclipse Requirements":

Install any of the following releases of Eclipse Foundation's Eclipse Development Platform on the supported platforms of your client computer:

   - Eclipse 3.5 (Galileo)
   Note: CA SCM Plug-In for Eclipse Release 12.1 has been tested with the Eclipse 3.5 Classic configuration only.
 
   - Eclipse 3.4 (Ganymede)
   Note: CA SCM Plug-In for Eclipse Release 12.1 has been tested with the Eclipse 3.4 Classic configuration only.
 
   - Eclipse 3.3
 
   Note: Eclipse 3.2 is not supported.
 

There are various configurations of the supported Eclipse releases available on http://www.eclipse.org (Classic, Java EE, and so on). Download the appropriate Eclipse configuration depending upon the type of Eclipse projects or applications being developed.

The Release 12.1 Eclipse plug-in is not supported on the 64-bit version of the Eclipse IDE. You must download the win32-bit version of the IDE.

Your Eclipse installation must include the Eclipse Graphical Editing Framework (GEF) plug-in. If your Eclipse distribution does not include GEF, you must install GEF prior to installing the CA SCM Plug-In for Eclipse.
Verify that the GEF builds include the zest binaries before you install the plug-in.

Note: For information about GEF, see http://www.eclipse.org/gef/ GEF downloads and installation instructions.

Important! Make sure to download the version of the Eclipse GEF plug-in that corresponds to the release of Eclipse that you are using.

More specifics about GEF and JDK requirements are on the next couple of pages in the Release Notes.

Since RAD 7.0 is based on Eclipse 3.2, RAD 7.0 is not supported with the SCM 12.1 Eclipse Plug-in.

However, you can use an SCM 12.0 client environment to communicate with a SCM 12.1 server. For those who cannot upgrade to RAD 7.5, they can continue to use the SCM 12.0 FP2 client and Eclipse Plug-in in their RAD 7.0 environment with no problems.