Probes failing after upgrade to 9.02

Document ID : KB000122453
Last Modified Date : 18/12/2018
Show Technical Document Details
Issue:
After upgrading from 8.5.1 to 9.0.2, the install completes successfully but several probes are in a failed stated after the upgrade is completed.

The failed probes all have a dependency on the data_engine which is running with a value for both the PID and port, but records the following messages in the log file:

de: get_connection_string - from <primary hub IP address>\<local port>
de: Must be using SQL Sever Express edition in restricted mode

The data_engine is configured to connect to an MSSQL Server 2016 database.
Environment:
UIM 9.02
MSSQL Server 2016
Cause:
During the upgrade, the provider key value in the <setup> section of the data_engine probe is left with the original ADO provider designation:

provider = SQLOLEDB

For MSSQL Server 2016, the data_engine must use the 11.0 SQL Native Client that should be installed as part of the UIM 9.02 upgrade installation:
Resolution:
From the data_engine probe's Raw Configure GUI, select the setup folder from the left-hand pane, then Modify the following key in the right-hand pane:

provider = SQLNCLI11

Apply the change.
Restart the robot so that all of the probes are restarted.