Probe deployment fails to a robot on a DMZ

Document ID : KB000105430
Last Modified Date : 08/08/2018
Show Technical Document Details
Issue:
We are trying to deploy the cdm probe to a robot on a DMZ but the deployment fails both via IM and Admin Console. The below error is reported in automated_deployment_engine.log:
 
FATAL AbstractActor - Error encountered during distribution of cdm to target /***/***/***: (4,Install Failure)
com.nimsoft.ADE.core.DeploymentException: (80) Session error, Unable to open a client session for *IP*:48000: Connection timed out: connect
	at com.nimsoft.ADE.actor.ProbeActor.install(ProbeActor.java:87)
	at com.nimsoft.ADE.actor.ProbeActor.install(ProbeActor.java:38)
	at com.nimsoft.ADE.actor.AbstractActor.run(AbstractActor.java:76)
	at java.util.concurrent.Executors$RunnableAdapter.call(Unknown Source)
	at java.util.concurrent.FutureTask.run(Unknown Source)
	at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
	at java.lang.Thread.run(Unknown Source)
Environment:
UIM 8.51
Cause:
If you have a firewall blocking communication from the UIM hub to the remote robot on port 48000 the deployment will fail.
Resolution:
Open the necessary ports in the firewall.
The following documentation link contains information on all required ports in a UIM environment:

https://docops.ca.com/ca-unified-infrastructure-management/8-5-1/en/getting-started/ca-uim-security#CAUIMSecurity-PortRequirements