Privileged Account who has one or more lowercase at user name cannot be update password while check-in or out on ORACLE Endpoint for SAM

Document ID : KB000057257
Last Modified Date : 14/02/2018
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Issue:

When user tries to change password via SAM for Privileged Accounts who has one or more lowercase at user name,

he/she got following error:

Error: Check in Privileged Account. ORAMetaConnector: eTORAAccountName=samuser01,eTORAAccountContainerName=Accounts,eTORADirectoryName=ORACLEserver,eTNamespaceName=Oracle Server,dc=im,dc=etasa"

 

 

 

Environment: 

 OS: Windows 
 Products: CA Privileged Identity Manager r12.9 SP1 or previous for SAM.
 Endpoint type: Oracle Server
  

Cause:

 ORACLE username is defined upper case when customer creates via ORACLE Enterprise Manager if enter lowercase.
 But when he/she creates user via SQLPlus with lowercase, it defined lower case.
 
 PIM tries to search Privileged Accounts with uppercase via Java Connector Server(JCS) when JCS change password on Endpoint.
 So, it fails since JCS can't find lower case user.
 
 This current  limitation since JCS version in PIM is old.

 

Workaround:

 please create Privileged Accounts with only uppercase user.