Predefined Variable, “&$PHYS_DATE_format#” fails when used as a default value in PromptSets if date format not YYYY_MM_DD

Document ID : KB000085075
Last Modified Date : 14/04/2018
Show Technical Document Details
Issue:
Error Message :
N/A

When using the variable &$PHYS_DATE_format# as a default value in a PromptSet with a date type element, you must use the following format to ensure that the date can be interpreted correctly by the Automation Engine.

&$PHYS_DATE_YYYY_MM_DD_d#
 
If any other date format is used, the variable will not evaluate correctly.

Investigation
  1. Define a test PromptSet with a default value today (2016-10-13) with a different variable date format such as &$PHYS_DATE_ DD_MM_YYYY_d#.
  2. Execute the job with the PromptSet and click OK without changing the input mask.
  3. The PromptSet will be saved as ‘0013-00-16’.
Following is a screenshot of a PromptSet using the correct date format for the variable &$PHYS_DATE_format# (i.e. &$PHYS_DATE_YYYY_MM_DD_d#) for the default value. 
 
0EMb0000001QgcJ.png
Environment:
OS Version: N/A
Cause:
Cause type:
By design
Root Cause: To use a default value for a date PromptSet-element, you have to use the format YYYY-MM-DD. You can see that also in the prompset designer, before you enter a value. The value should be set to use &$PHYS_DATE_YYYY_MM_DD_d#.
Resolution:
Update to a fix version listed below or a newer version if available as a tooltip icon will be implemented in order to ensure correct usage of the time format.

Fix Status: Released

Fix Version(s):
Automic Web Interface 12.1.0 - Available
Additional Information:
Workaround :
N/A