PPM Upgrade failing with error java.lang.NoClassDefFoundError java/sql/Connection on class com.compuware.apm.agent.introspection

Document ID : KB000124160
Last Modified Date : 07/01/2019
Show Technical Document Details
Issue:
During upgrade for PPM, the following error message is thrown in install.log:

PPM Upgrade failing with error java.lang.NoClassDefFoundError java/sql/Connection on class com.compuware.apm.agent.introspection
 
1/03/19 9:22 AM (ExecTask) Exception in thread "main" java.lang.NoClassDefFoundError: java/sql/Connection
1/03/19 9:22 AM (ExecTask) at com.compuware.apm.agent.introspection.jdbc.ConnectionPoolIntrospection.updateConnectionClass(ConnectionPoolIntrospection.java:214)
1/03/19 9:22 AM (ExecTask) at com.sun.proxy.$Proxy4.prepareCall(Unknown Source)
1/03/19 9:22 AM (ExecTask) at com.niku.union.persistence.utils.Utils.createStatementInternal(Utils.java:704)
1/03/19 9:22 AM (ExecTask) at com.niku.union.persistence.utils.Utils.createStatement(Utils.java:668)
 
Cause:
This issue is not caused by the PPM product, it's caused by a customization (third party product):
com.compuware.apm.agent.introspection
Dynatrace by Compuware
This is not a PPM Java class.
Resolution:
After checking with Dynatrace support, customer found that the Dynatrace service called RUM (Real User Monitoring) made the install to fail.
To resolve this they had to disable RUM, upgrade the PPM application and enable it again when complete.