PPM - MSP - 'Compile error: Variable not defined.'

Document ID : KB000124411
Last Modified Date : 11/01/2019
Show Technical Document Details
Issue:
--STEPS TO REPRODUCE--

1.  Open a project in PPM
2.  Click 'Open in Scheduler'
3.  Click Microsoft Project [Read-Write]

Expected Result - Project opens in MSP
Actual Result - Receive error message:

Compile error: Variable not defined.

 
Resolution:
1. Open MSP from the desktop or Start menu 
2. Open a blank project 
3. In MSP, go to View > Macros > Visual Basic 
4. Expand ProjectGlobal then Expand Modules 
5. Select each of the four modules starting with either CA_ or Niku_ (select one at a time) 
6. On the module Properties window right beneath the 'Project - ProjectGlobal' window, click on the Name under the 'Alphabetic' tab. 
7. Remove the 1 from the module name and click away. Do this for each of the four modules. 
8. Go to File > Save Global.MPT 
9. Go to File > Save and Return to Microsoft Project