Portal console is not responding and unable to access vsm files

Document ID : KB000006801
Last Modified Date : 14/02/2018
Show Technical Document Details
Issue:

Even though the server components are running we are not able to login to devtest portal and the vsms are not accessible. We could see the below errors in the server log. 

 [ServerRequestResponder 279] ERROR com.itko.lisa.net.ServerRequestHandler - Error decoding message, this is really hosed! 

com.itko.jms.JMSException: Failed to build body from bytes. Reason: java.io.InvalidClassException: org.springframework.security.core.authority.SimpleGrantedAuthority; local class incompatible: stream classdesc serialVersionUID = 400, local class serialVersionUID = 410 

at com.itko.activemq.util.JMSExceptionSupport.create(JMSExceptionSupport.java:35) 

at com.itko.activemq.command.ActiveMQObjectMessage.getObject(ActiveMQObjectMessage.java:191) 

at com.itko.lisa.net.ServerRequestHandler.traceMessage(ServerRequestHandler.java:390) 

at com.itko.lisa.net.ServerRequestHandler.processRMIMessage(ServerRequestHandler.java:458) 

at com.itko.lisa.net.ServerRequestHandler.access$300(ServerRequestHandler.java:67) 

at com.itko.lisa.net.ServerRequestHandler$4.run(ServerRequestHandler.java:357) 

at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511) 

at java.util.concurrent.FutureTask.run(FutureTask.java:266) 

at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142) 

at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617) 

at java.lang.Thread.run(Thread.java:745) 

Environment:
Devtest: 10.0
Cause:

       When migrating from old version to Devtest 10.0, you might have copied complete directory of vseDeploy folder under <Devtest_Home>. This vseDeploy has .tracking folders and .services files apart from mar files. 

       We should not copy .tracking and .services files which are generated in one version to other version. Instead you can deploy the previous mar files through portal or deploy services through workstation.

Resolution:

There is a patch exists for login to portal issue after migrating from previous version to Devtest 10. Please raise support request and get the details.