Portal Application Sync Not Working If Using Legacy Portal Bundle

Document ID : KB000100729
Last Modified Date : 09/06/2018
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Issue:
  • The CA API Gateway ("Gateway") may not sync applications with the CA API Developer Portal ("Portal") when legacy Portal bundles are used on the Gateway.
    • Bundles affected are those built pre-March 2016.
Environment:
  • This issue can affect Gateway nodes integrated with Portal version 4.2.7 in SaaS environments (released June 11 & 12, 2018), and Gateway nodes integrated with on-premise Portal version 4.2.7.1, specifically if the Gateway nodes are using a Portal bundle dated prior to March 2016.
Cause:
  • This issue is caused by a mix of older Portal bundle versions/build dates, and a table name change in the database.
Resolution:
  1. Update the Portal bundle on the Gateway to the latest version.
  • It is considered best practice to update the Portal bundles during the upgrade process, as noted in the documentation. This issue should not be seen as long as that best practice is followed.
    • The process of updating the Portal bundle on the Gateway involves a restart of the Gateway service on each node in the cluster before it takes effect.
Additional Information: