Policy Validation Results in, "Unable to retrieve service properties"

Document ID : KB000008017
Last Modified Date : 14/02/2018
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Issue:

When I attempt to use the API Gateway Policy Manager to validate policies, I run into the following error: 

 

Screen Shot - validating pop up error.png

 

It is possible you may run into a more generic error:

 

Memory.PNG

Environment:
Windows
Cause:

The likely cause of the issue is Java memory allocation.

Before proceeding with the steps to increase the java memory allocation, please verify you see the following errors in the Policy Manager log called ssm0.log.

The ssm0.log is notmally located in following directory:

<root_drive>:\Users\<your_OS_user_name\.l7tech

Check the log for the following line: 

Caused by: java.lang.OutOfMemoryError: Java heap space

Resolution:

If you see Java heap space messages in the ssm0.log, the resolution is to increase the amount of memory allocated to the Policy Manager. 


The policy manager .ini file defines how much memory can be allocated to the application. It is normally located in the installation path of the Policy Manager but it could be anywhere you specified during the installation. For example :

C:\Program Files (x86)\CA Technologies\CA API Gateway Policy Manager 9.2.00\CA API Gateway Policy Manager.ini

or for older versions:

C:\Program Files (x86)\Layer 7 Technologies\Layer 7 Policy Manager 8.2.00\Layer 7 Policy Manager.ini

Resolution Steps:

  • Make a backup copy of the ini file and save it into a backup directory of your choice
  • Edit the original file with notepad or some other text editor.
  • Change "-Xmx256M" to "-Xmx512M".
    Restart the Policy Manager 
  • Test.

By default, Automatic policy validation is enabled. If it is causing problems you can disable the automatic validation via the following steps in Policy Manager

File -> Preferences -> Policy Validation Feedback