Policy Server take long time to Stop

Document ID : KB000007934
Last Modified Date : 14/02/2018
Show Technical Document Details
Issue:

When customer is using the Oracle as user directory and  using WAMUI to view contents of this user directory.

Policy server shutdown on Linux is taking long time and hanging  until the script internally issues

 

SIGKILL  to exit.

stop-all needs to kill process

[root@xyz siteminder]# ./stop-all

./stop-all[45]: .: syntax error at line 6: ewline' unexpected

RiskMinder is not running

SiteMinder Policy Server is stopping.....................

There was a problem stopping the Policy Server

Using SIGKILL to stop the Policy Server

SiteMinder Health Monitor is stopping..

SiteMinder Health Monitor is no longer running

 

PS tracelogs:

[05/17/2016][12:00:32.803][12:00:32][27495][4151752416][CServer.cpp:4636][][][][][][][][][][][][][][][][][][][][][][LogMessage:INFO:[sm-Server-01960] smpolicysrv waiting for threads to terminate]

[05/17/2016][12:00:32.803][12:00:32][27495][4151752416][CServer.cpp:4637][][][][][][][][][][][][][][][][][][][][][][LogMessage:INFO:[sm-Server-01970] smpolicysrv proceeding with shutdown]

[05/17/2016][12:00:32.803][12:00:32][27495][4151752416][CServer.cpp:4656][][][][][][][][][][][][][][][][][][][][][][LogMessage:INFO:[sm-Server-01980] 

Environment:
Policy Server: R12.52 SP1 CR4 OS: RHEL 6 64bitsUser Store: Oracle SQL 12c
Cause:

The issue is with the ODBC provider instance release mechanism.

The shutdown is blocked at a point in the DB manager where the DB interface release mechanism not properly called

Resolution:

This issue has been resolved in Policy Server 12.52 SP1 CR6 and above:

 

https://docops.ca.com/ca-single-sign-on/12-52-sp1/en/release-notes/cumulative-releases/defects-fixed-in-12-52-sp1-cr06