Planned Bennefit is set to 0 after xogging in a service

Document ID : KB000095044
Last Modified Date : 06/09/2018
Show Technical Document Details
Issue:
STEPS TO REPRODUCE:

1. Go to Home > Service Management > Services
2. Create a service "My Srv"
3. On the Financial Summary Page > Populate the Planed Cost and Planned Benefit data
4. Home > Portfolio Management > Create a portfolio 
5. On the Contents Editor tab and the service above and Sync the portfolio
6. Go to the portfolio Investments tab and look to the data present. Cost plan and benefit plan data is present
7. Do a XOG update of the service with the xml below:
<?xml version="1.0" encoding="UTF-8"?>
<NikuDataBus xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:noNamespaceSchemaLocation="../xsd/nikuxog_service.xsd">
  <Header action="write" externalSource="NIKU" objectType="service" version="8.0"/>
  <Services>
    <Service name="rafa srv" objectID="rafa_srv">
    </Service>
  </Services>  
</NikuDataBus>
8. The update is successful.
9. Sync the portfolio and go back to the Investments tab

Expected Result: Service Planned Benefit data to be shown
Actual Result:  Service Planned Benefit data has been zeroed out

 
Cause:
This is caused by DE42689 
Resolution:
This is now fixed within PPM 15.5 and has been back ported to 15.4.1.2

The problem here was the xog file used. 
These tags were added to the xml file:
plannedBenFinish 
plannedBenStart 
The above fields were being used, but not the: 
plannedBenTotal 

Either all of them need to be used or none. 
As soon as you give the start and finish, but not the total, then plannedBenTotal is set to 0 

The attribute default is set to 0, because is not mentioned while start and finish are specified

Workaround: 
1.    Go to the Service itself and do a save action. Re-sync the portfolio
2.    Ensure the Planned benefit details are present on the XOG file