PeopleSoft version defined in the ESP Agent for PeopleSoft agentparm.txt file.

Document ID : KB000053568
Last Modified Date : 14/02/2018
Show Technical Document Details

Description

Is PeopleSoft version defined in the ESP Agent for PeopleSoft agentparm.txt file important?

Solution

The agentparm.txt file of the ESP Agent for PeopleSoft has the statement 'ps.version=' which is assigned to the value of the version of the PeopleTools, e.g.

ps.version=8.47

The Agent works with the data of the PeopleSoft Process Scheduler table, and must know the structure of this table that is in use.

The Scheduler table structure could change from one version to another of PeopleTools so it is important to set a proper value for the 'ps.version' in the agentparm.txt file otherwise the Agent would malfunction.

It could happen that the Agent continues to work fine although the 'ps.version' still keeps a version number older then your current PeopleTools. This could mean that the Scheduler table structure was not changed with the PeopleTolls version upgrade.
In order to avoid any trouble with the Agent functionality we strongly recommend to keep the value of the 'ps.version' statement adjusted to the current version of your PeopleTools.