PeopleSoft agent wrong ELF Class

Document ID : KB000084693
Last Modified Date : 14/04/2018
Show Technical Document Details
Issue:
Error Message :
U2004075 Error 'libjvm.so: wrong ELF class: ELFCLASS64'

When starting the Agent for PeopleSoft, the user is receiving an error mentioning an incorrect ELF Class:
U2004075 Error 'libjvm.so: wrong ELF class: ELFCLASS64'
 
Investigation
This means that 64-bit Java is in use.
Cause:
Cause type:
Configuration
Root Cause: Did not install the 32-bit Java and environment variable was not set up correctly.
Resolution:
Install a 32-bit Java.

If the issue is still persistent, modify the PATH environment variable similar to this:

 
PATH=/u01/app/automic/jdk/jdk1.7.0_79/jre/lib/amd64/server:$PATH;export PATH

Specify the directory where the libjvm.so (or libjvm.sl, the .xx is OS-specific) resides in the FIRST position of the PATH variable.

If the solution provided does not resolve the issue, please send the following information to Support for further analysis:
  1. Screenshot results of ENV command
  2. PS agent log 


Fix Status: No Fix

Fix Version(s):
N/A
Additional Information:
Workaround :
N/A