PDS Problems to upgrade model from 8.1 to 8.7 CPF3204 errors running YAPLMDLCHG

Document ID : KB000016022
Last Modified Date : 14/02/2018
Show Technical Document Details
Introduction:

CPF3204 errors upgrading from 8.1 to 8.7 running YAPLMDLCHG

Question:

I am seeing this error message in the output when running YAPLMDLCHG

 

CPF3204 Diagnosmeddelande 40 17-10-03 09:04:50,725680 QDBCRTME QSYS 2026 QLICRDUP QSYS 

Meddelande . . : Cannot find object needed for file YMDLLST10L in YAMDL. 

Cause . . . . . : Either library YAMDL or member YMDLLSTRFP or file 

YMDLLSTRFP in library YAMDL was not found. 

 

What could cause this?

Environment:
AS400 Iseries
Answer:

The file YMDLLSTRFP was missing the standard empty member YMDLLSTRFP. 

To solve this: add member YMDLLSTRFP to file YMDLLSTRFP and try your YAPYMDLCHG 

again.