PDM_K_REINDEX utility is not completing successfully. Following error is seen in the EBR log EBR::REINDEX::Reindexing completed with errors STDLOG contains a number of messages similar to: EBR::REINDEX::document #405925::text fields are empty

Document ID : KB000009076
Last Modified Date : 14/02/2018
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Issue:

PDM_K_REINDEX utility is not completing successfully.

Following error is seen in the EBR log

EBR::REINDEX::Reindexing completed with errors

STDLOG contains messages similar to the following:

<SDM Hostname> pdm_k_reindex 9000 SIGNIFICANT bpebr.c 4273 EBR::REINDEX::document #405925::text fields are empty

<SDM Hostname> pdm_k_reindex 9000 SIGNIFICANT BPebrReindex.c 2270 EBR::REINDEX::Indexing of document ID: KD:405925 failed with status 0.

Environment:
Service Desk Manager 12.9, 14.1 and 17.xAll Supported Operating Systems
Cause:

The above STDLOG error message appears if the associated Knowledge Document has an empty Title, Summary, Problem or Resolution field.

Resolution:

Check the Knowledge Documents referenced in the STDLOG error (KD:405925 in the sample error above) and ensure that the document does not have an empty Title, Summary, Problem or Resolution field.

Once all the Knowledge Documents referenced have been corrected, re-run the PDM_K_REINDEX utility

Additional Information:

https://docops.ca.com/ca-service-management/14-1/en/reference/ca-service-desk-manager-reference-commands/technical-reference/ca-sdm-pdm-database-commands#CASDMPDMDatabaseCommands-pdm_k_reindex--KnowledgeRe-IndexUtility