Patches Skipped with 'NOT required' status during UPM Rollup patch deployment

Document ID : KB000094884
Last Modified Date : 11/05/2018
Show Technical Document Details
Introduction:
When we deploy a Patch Manager Rollup bundle via CA Client Automation, not every patch is installed. Some of the patches are ignored with a 'Not Required' status in the MS_OS_Rollup_xxxxx.log.

Example:
Patch windows8.1-kb4014595-x64.msu is NOT required
Patch Windows8.1-KB4034672-x64.msu is already installed
Patch Windows8.1-KB4040958-x64.msu is NOT required

All the patches are installed when the Rollup bundle is installed manually.
 
Question:
Why are some patches in the Patch Manager Rollup bundle skipped with the 'NOT required' status?
Environment:
All versions of CA Patch Manager
Answer:
The 'NOT required' status is shown in the log, if the relevant application is not installed on the target.

For example patch KB4040958 is applicable to Microsoft .NET Framework 4.5.2.
https://support.microsoft.com/en-us/help/4040958/description-of-the-security-only-update-for-the-net-framework-4-5-2-fo

Suppose Microsoft .NET Framework 4.6.1 is detected on the target, patch KB4040958 will be skipped during the Rollup installation, since it is applicable only to Microsoft .NET Framework 4.5.2.

Note: CA Patch Manager determines the version of the application installed on a target using the discovered Software Inventory. This inventory is listed under the Computer->Software->Discovered section in the DSM Explorer.

User-added image