PANMODI/PVPVLAMS VERSION NOT COMPATABLE

Document ID : KB000052567
Last Modified Date : 14/02/2018
Show Technical Document Details

Description:

When I attempt to compile maps I receive this error, Why?
+PV999 *PANVALET INTERNAL ERROR
+PANDIAG PANI072 AT 00000180: PANMODI/PVPVLAMS VERSION NOT COMPATABLE NEED 14.4

Solution:

PAM would call PVPVLAMS.

Usually this error is caused by a version mismatch between a user program that has PAM linked into it and the 14.5 PANMODI module. Relinking the user program with the 14.5 PAM should resolve this.
Sample JCL below:

 //IEWL     EXEC PGM=IEWL,                                       
 //             PARM='SIZE(512K,64K),CALL,LET,LIST,XREF'         
 //SYSLIB   DD  DSN=user.auto.include.library,DISP=SHR           
 //SYSUT1   DD  UNIT=SYSDA,SPACE=(CYL,(2,1))                     
 //SYSPRINT DD  SYSOUT=*                                         
 //SYSLMOD  DD  DSN=user.load.library,DISP=SHR                    
 //PANLMOD  DD  DSN=panvalet.load.library,DISP=SHR                
 //SYSLIN   DD  *                                                 
 INCLUDE PANLMOD(PAM)                                             
 INCLUDE SYSLMOD(userpgm)                                         
 ENTRY userpgm                                                    
 NAME userpgm(R)                                                  
/*