PAM View button not working

Document ID : KB000115940
Last Modified Date : 27/09/2018
Show Technical Document Details
Issue:
CA Privileged Access Manager pages that have lists can't be accessed. You will not be able to create new filters such as Access page, Sessions, Users, Devices, Accounts, and so on.
Environment:
PAM 3.2
Cause:
Caused by:
Internal Exception: com.mysql.jdbc.exceptions.jdbc4.MySQLSyntaxErrorException: Table 'cspm.user_filter_view' doesn't exist
Error Code: 1146
Call: SELECT ID, is_default, details, table_name, user_name, view_name FROM user_filter_view WHERE ((user_name = ?) AND (table_name = ?)) ORDER BY UPPER(view_name) ASC
        bind => [2 parameters bound]
Query: ReadAllQuery(referenceClass=UserFilterView sql="SELECT ID, is_default, details, table_name, user_name, view_name FROM user_filter_view WHERE ((user_name = ?) AND (table_name = ?)) ORDER BY UPPER(view_name) ASC")
Jul 16, 2018 2:30:39 PM com.ca.pam.rest.UserFilterViewService getAll
 
Resolution:
Fix has been applied on PAM 3.2.2 release and is available for download: 
https://support.ca.com/us/product-content/recommended-reading/technical-document-index/ca-privileged-access-manager-solutions-patches.html