PAM upgrade from 3.0.2 to 3.1.1 failed with "PAM-CMN-1264: Upgrade failed. Please review the audit log and then perform a system recovery" error message

Document ID : KB000106957
Last Modified Date : 18/07/2018
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Issue:
I have attempted to upgrade PAM 3.0.2 to 3.1.1. After reboot the following upgrade error message occurred.

PAM-CMN-1264: Upgrade failed. Please review the audit log and then perform a system recovery.

 
Environment:
PAM 3.0.2
Cause:
This is a known bug related to failure of altering kdc_server table.
If logs.bin file is collected CA Technical Support can find the following error in the installation log.

--------------
ALTER TABLE `uag`.`kdc_server`
DROP FOREIGN KEY `kdc_server_ibfk_1`
--------------

Mysql schema update of file 3.1.0_upgrade.sql failed 1, we're going to abort
Resolution:
The CAPAM_3.0.2.17 hotfix resolves this issue.
Please go to

https://support.ca.com/us/product-content/recommended-reading/technical-document-index/ca-privileged-access-manager-solutions-patches.html

and download CAPAM_3.0.2.17 hotfix. Apply this hotfix firstly before upgrading to 3.1.1.