PAM login page is not shown after a recent installation

Document ID : KB000008323
Last Modified Date : 14/02/2018
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Issue:

PAM login page is not shown after a recent installation.

Cause:

Reviewing c2o.log file, the next message can be seen:

 

2017-10-13 14:46:37,585 ERROR [org.apache.coyote.ajp.AjpProtocol] [ main] Error initializing endpoint
java.net.BindException: Address already in use: JVM_Bind servername.domain.com/11.22.33.444:8009

 

This error message means that Tomcat port is used by another application installed on the same PAM server, that's why login page is not displayed.

Resolution:

In order to change the port used by Tomcat, the next steps can be followed:

1.- Stop PAM services and edit OasisConfig.properties
2.- Search for line "tomcat.connector.ajp.port" and change it for a valid port.
3.- Start PAM services again.

Additional Information:

In order to avoid port conflicts, Process Automation's Orchestrator must be installed on a server without any other application installed in it.