Out-Of-The-Box ACC access causes browser certificate error

Document ID : KB000046278
Last Modified Date : 14/02/2018
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Issue:

Out-Of-The-Box Agent Command Center(ACC) Configuration Server access causes browser certificate error.

A user who tries to connect to an ACC Configuration Server by using Windows Internet Explorer (or any web browser) may receive the following warning message:

"There is a problem with this website's security certificate. The security certificate presented by this website was not issued by a trusted certificate authority.

Security certificate problems may indicate an attempt to fool you or intercept data you send to the server.

We recommend that you close this webpage and do not continue to this Web site."

 

Environment:

CA APM 10.2 or above

 

Cause:

ACC Configuration Server comes with SSL port enabled OOTB by default and because its self-signed certificate that gets created when it first starts up is not trusted by any authority, a user may get this web browser client side error.

 

Resolution:

Change "webserver.https.enable=true" to "webserver.https.enable=false" in its config file, "apmccsrv.properties".

Restart the ACC Configuration Server.

Clear out the web browser's cache.

Connect to a ACC Configuration Server on a default HTTP port, 8088, via a web browser.

 

Additional Information:

"There is a problem with this website's security certificate" when you try to visit a secured website in Internet Explorer