OSB error message after agent upgrade

Document ID : KB000094237
Last Modified Date : 03/05/2018
Show Technical Document Details
Issue:
I have OSB server with 10.1 agent. After upgrading to 10.7 version many error messages as below:

[ERROR] [IntroscopeAgent.Agent] Unable to create tracer factories for the following class (library not found): com.wily.powerpack.alsb.tracer.BSReturnTracer
Environment:
Any agent version
Cause:
According to the error (see com.wily.powerpack.alsb.tracer.TransportTracer):

[ERROR] [IntroscopeAgent.Agent] Unable to create tracer factories for the following class (library not found): com.wily.powerpack.alsb.tracer.TransportTracer

It mentions it can´t find the class "com.wily.powerpack.alsb.tracer.TransportTracer" and this class is in OSBagent.jar. You can open "OSBagent.jar" with 7zip for instance and you will see that class is located in "...\core\ext\OSBAgent.jar\com\wily\powerpack\alsb\tracer\" so once the OSBagent.jar file is in the right place it should be able to find the classes.
Resolution:
This is resolved by moving the OSBAgent.jar to the "ext" folder of the agent:

- Stop the agent
- Go to "Agent_home\examples\SOAExtensionForOSB\ext" directory, copy OSBAgent.jar file and paste the jar in "Agent_home\core\ext" directory
- Start the agent
.