OS Definition missing / platform unclassified

Document ID : KB000100364
Last Modified Date : 15/06/2018
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Issue:
Sometimes new operating system versions come out and ITCA/ITCM does not have the information required to properly classify the operating system as it does not match any existing OS Profiles in the MDB database or is not defined in the current \CA\DSM\AGENT\OSCONFIG.XML file...or sometimes both. The prior is addressed by new signatures and data published by CA Technologies and downloaded via the 'Software Content Downloads' engine task populated into the 'System Engine' by default. This combined with OS Definitions in OSConfig.xml allow any supported OS to be detected and reported properly.
 
Environment:
Windows 10 Pro Workstation systems version 1709  and possibly others.
Cause:
Missing MDB data because of unused or non-functioning Software Content Downloads can be corrected separately, but even if that is up to date, this alone cannot resolve the issue in this case.
Windows 10 Pro Workstation introduced changes that prevented it's proper detection by the product, instead causing it to be reported as 'Unclassified' because the existing OSCONFIG.XML file in ITCA / ITCM 14 SP2 (14.2) does not contain the proper additional required structure to detect Windows 10 Pro Workstation, due to changes made by Microsoft to the OS.
Resolution:
The core cause of the issue is a new custom config.xml file that can be obtained by opening a support request for (T55V168)

If you also lack proper MDB OS identification information because you cannot use Software Contents download, you can open an issue with the support team to provide you with an export of the current CA Provided Signature/Database content, which you can manually import into your manager database to bring it up to date. The process below will outline what to do with this export to get the data into your database:
  1. Download export.zip attached to the ticket and extract it on the Domain Manager; record the path to the extracted files.
  2. Browse to CA\DSM\BIN and fine the file contentutility.exe
  3. There should also be a file called ‘content_utility.xml’. If not, double-click ‘contentutility.exe’ and one will appear*
  4. Open ‘content_utility.xml’ in notepad or notepad++
  5. It should be edited to look like the below (Only the items in purple/bold are important here):
 
<contentutility_configuration>
<general>
<datadirectory>PATH TO EXTRACTED FILES</datadirectory>
</general>
<export>
<manager>
<hostname>nothing</hostname>
<enabled>no</enabled>
<ca_provided>yes</ca_provided>
<custom_created>no</custom_created>
<ca_intellisig>no</ca_intellisig>
<custom_intellisig>no</custom_intellisig>
<intellisig_detail>no</intellisig_detail>
</manager>
</export>
<import>
<manager>
<hostname>DOMAIN MANAGER NAME</hostname>
<enabled>yes</enabled>
<ca_provided>yes</ca_provided>
<custom_created>no</custom_created>
<ca_intellisig>no</ca_intellisig>
<custom_intellisig>no</custom_intellisig>
<intellisig_detail>no</intellisig_detail>
</manager>
</import>
</contentutility_configuration>
 
  1. Once that file is updated and saved, right-click on ‘contentutility.exe’ and select ‘run as administrator’.
  2. Wait for the process to complete.
  3. When done, run your query again to verify updates were made to the database.