Oracle User Validation Error during WAAE upgrade

Document ID : KB000073061
Last Modified Date : 12/03/2018
Show Technical Document Details
Issue:
When performing an upgrade, the WAAE installer is unable to validate the Oracle credentials.

The following errors are logged:

Unable to determine if the CA Workload Automation AE instance is using CA EEM security as the autosec_test STAT command failed.
Unable to login to the event server <EventServer> as the autosys user. Check the password in the config.<AUTOSERV> file and try again.


Oracle User Validation Error during WAAE ugprade

We validated the following:
  • The password for the aedbadmin Oracle user is correct. Verified by connecting via SQLPLUS.
  • The encrypted password for the autosys Oracle DB user is correct in the $AUTOUSER/config.$AUTOSERV. Compared the password hash with the "Get encrypted password." option of the autosys_secure utility.
Environment:
CA Workload Automation AE 11.3.6 SPx  with Oracle Event Server on Enterprise Linux or UNIX OS.
Cause:

The Oracle database connectivity failure during the upgrade was due to incorrect values for the Oracle variables ORACLE_HOME and TNS_ADMIN in the $AUTOUSER/autosys.bash.<hostname> environment file.

The installer uses the root user's $SHELL environment variable setting to source the corresponding WAAE environment file from $AUTOUSER directory. 

For example, if root user defaults to the Bash shell (/bin/bash), then the $AUTOUSER/autosys.bash.$HOSTNAME environment file is sourced during the installation.
 
Resolution:

Verify the environment variables ORACLE_HOME, TNS_ADMIN, LD_LIBRARY_PATH (includes $ORACLE_HOME/lib) are correctly specified in the following environment files in the $AUTOUSER directory.
  • autosys.sh.$HOSTNAME
  • autosys.ksh.$HOSTNAME
  • autosys.bash.$HOSTNAME
  • autosys.csh.$HOSTNAME