ORA-24248: XML DB extensible security not installed

Document ID : KB000008937
Last Modified Date : 14/02/2018
Show Technical Document Details
Issue:

After installing the Oracle repository, setting up the connection profile, and testing the connection, we are receiving the following error: ORA-24248: XML DB extensible security not installed.

Environment:
CA Test Data Manager (TDM)- Datamaker, Oracle
Cause:

If you or your DBA did not install the Oracle XML database, you will receive this error message. A default installation of Oracle will include these features and packages. In Oracle releases prior to 11g, the only way to limit access to the network via these packages was to restrict privileges on the packages. So if you have restrictions on your environment (especially Cloud platforms) where Oracle was installed, you may see this error. 

Resolution:

To resolve this issue, please reach out to your database administrator (DBA) and they will be able to work with you to find the root cause. You will either need to install the XML DB or have the restrictions lifted in your environment. 

If you have an Oracle Support account, you can sign in and use the resolution from this knowledge document: https://support.oracle.com/knowledge/Oracle%20Database%20Products/825075_1.html 

If you do not have an Oracle support account, this document also reviews how to resolve this: http://oracleflash.com/40/ORA-24248-XMLDB-extensible-security-not-installed.html 

Additional Information:

If you experience any further issues, please open a support case by going to https://support.ca.com/us.html