"ORA-00600 internal error code" error during PPM upgrade or applying PMO, or in logs when running jobs or using PPM

Document ID : KB000125045
Last Modified Date : 21/01/2019
Show Technical Document Details
Issue:
Error message similar to:
11/18/18 6:38 PM (ExecTask) at com.niku.dbtools.Utilities.run(Utilities.java:1862)
11/18/18 6:38 PM (ExecTask) at com.niku.dbtools.Utilities.main(Utilities.java:975)
11/18/18 6:38 PM (ExecTask) Caused by: com.ca.clarity.jdbc.oraclebase.ddc: [CA Clarity][Oracle JDBC Driver][Oracle]ORA-00600: internal error code, arguments: [15598], [], [], [], [], [], [], [], [], [], [], []
11/18/18 6:38 PM (ExecTask) ORA-06512: at line 153
 
Or:
Caused by: com.niku.union.persistence.PersistenceApplicationException: java.sql.SQLException: [CA Clarity][Oracle JDBC Driver][Oracle]ORA-00600: internal error code, arguments: [17147], [0x7F89C7A228C8], [], [], [], [], [], [], [], [], [], []
 
 
The arguments after ORA-00600  can be different.
 
Cause:
This is an issue with Oracle, and not with Clarity data. All ORA-00600 would indicate a database problem.
 
Resolution:
Work with the DBA to open an issue with Oracle support to get the root cause and fix the problem. The error ORA-00600 is usually fixed by applying an Oracle patch.
 
Additional Information:
Reference:
http://www.dba-oracle.com/t_ora_00600_internal_error_code_arguments_string_%20string_string_string_string_string_string.htm