CDM install fails with "VS2017 dependency not found"

Document ID : KB000118823
Last Modified Date : 16/11/2018
Show Technical Document Details
Issue:
I am trying to deploy the new CDM 6.33 release, and it fails with the error "VS2017 dependency not found".

User-added image
 
Cause:
This error will be displayed if deploying CDM 6.33 to any robot version < 7.95/7.96 
The newer version of the probe requires a newer version of the  MS VD redist package as we removed the old unsupported versions from the product and made CDM use Microsoft Visual C++ Redistributable for Visual Studio 2017.
 
Resolution:
To fix this issue:

1. Download the following packages:

vcredist_x64
http://support.nimsoft.com/Files/Archive/00457/vs2017_vcredist_x64_zip-1.0.0-20180710.095502-1.zip

or

vcredist_x86
http://support.nimsoft.com/Files/Archive/00458/vs2017_vcredist_x86_zip-1.0.0-20180710.095502-3.zip

2. Deploy to the robot where you want to install CDM 6.33

3. Deploy CDM 6.33.

 
Additional Information:
•  This issue does not occur on robot 7.95 and 7.96 as the package is included in the controller.
•  Currently the Nimsoft Archive latest current version is vs2017_vcredist_x64 version = 1.01.
   downloading and using this version won't fix the problem as the probe needs version 1.00. If using 1.01 you may see the error:
   distsrv: Dependency check error: vs2017_vcredist_x64 version = 1.00 is required (1.01 found)