Operating System upgrade affect on Telon 2.4

Document ID : KB000043993
Last Modified Date : 14/02/2018
Show Technical Document Details

 

Question:

If we upgrade our Operating System from z/OS 1.13, 
to z/OS 2.2, will our current running version of Telon 2.4 have any problems? 

Environment: 

Telon 2.4, z/OS 1.13, z/OS 2.2, COBOL 4.2, COBOL 5.x
 

 

Answer: 

Only our current supported version of Telon 5.1 was certified with z/OS 2.2. 

 

If you are running fine with z/OS 1.13, you will probably be fine with z/OS 2.2

If you do have an error with your Operating System upgrade with an unsupported Telon

version, you will have to upgrade to a supported version of Telon. 

 

The problem with z/OS 2.x was that a new version of COBOL 5.x was available, that all versions of Telon 

had a problem with.

Telon generated COBOL programs may fail with ABEND U4008. This problem occurs 

only if COBOL 5.x version is being used. The fix is only available for Telon 5.1.

Users can upgrade their Operating system, without upgrading their COBOL compile and runtime option.  

 

Additional Information:

 This is a COBOL related problem. It shouldn't be a problem with your z/os upgrade. It is how Cobol 5.x is compiling its code into binaries.  If you have previously compiled Telon programs, Telon will have generated TGT TASK code, and using any Cobol before version 5.x, will be fine.
 If they have their COBOL 5.x in their runtime, and have Telon generated code that is referencing the TGT TASK area, the TGT has been removed from 5.x COBOL, and our Abnormal Termination program will abend.