Opening or launching CA Spectrum Event Configuration (ECEditor) takes many minutes and hangs OneClick

Document ID : KB000004173
Last Modified Date : 14/02/2018
Show Technical Document Details
Issue:

In CA Spectrum opening the Event Configuration GUI is locking up the entire OneClick client for several minutes.  During this time, nothing can be done and the OneClick java client freezes.  This is most notably seen for users that are launching OneClick through a VPN.

Cause:

There was an inefficiency in the way the EventFormat files were being loaded.

Resolution:

This is tentatively scheduled to be resolved in future release CA Spectrum 10.2.2 and above.  For CA Spectrum 10.2.1 there is a program temporary fix (PTF):

 Spectrum_10.02.01.PTF_10.2.152

The fix corrected the loading issue and ECEditor launches in an acceptable timeframe.

If you need a copy of the Spectrum_10.02.01.PTF_10.2.152 patch, please open a case with CA Support.

 

Additional Information:

This was previously seen in Spectrum 10.0 and 10.1 and resolved in 10.2.  However the fix did not include a performance change that was needed that is included in the Spectrum_10.02.01.PTF_10.2.152  patch (and in 10.2.2 and above).