Agile Central - On-Premises: Log Files Are Filling Disk

Document ID : KB000110092
Last Modified Date : 21/02/2019
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Issue:
An increase in traffic is causing the log files to consume more space than usual.  The disk is in danger of filling up, thereby crashing the appliance.
Environment:
Agile Central On Premise versions
  • 2016.2
  • 2017.1
  • 2018.1
Cause:
The request.log contains information from each request to the server.  In a busy environment, this log file can quickly grow to several gigabytes per day and in severe cases can exhaust available disk space.
 
Resolution:
A workaround is to force the logging subsystem to rotate and compress the file more frequently.

The file that controls the logging is: 
/home/appuser/appserver-config-latest/alm/webapps/slm/WEB-INF/classes/logback.xml 

Make a backup of that file
Example:
cp /home/appuser/appserver-config-latest/alm/webapps/slm/WEB-INF/classes/logback.xml /home

Edit that file and locate the following line: 
<fileNamePattern>${LOG_DIR}/request.log.%d{yyyy-MM-dd}.gz</fileNamePattern> 

(There are several lines that have the word "request" in them; make sure the line matches exactly) 

Modify the date pattern by adding a -HH: 
<fileNamePattern>${LOG_DIR}/request.log.%d{yyyy-MM-dd-HH}.gz</fileNamePattern> 

This will cause the log files to rotate on an hourly basis and compess the older logs more frequently.
After that you'll need to restart your Agile Central services in the control panel: 
Use The CA Agile Central And Search Services