NX_ATUS_CATALINA_BASE not found.

Document ID : KB000004515
Last Modified Date : 14/02/2018
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Issue:

TOMCAT is failing and are not able to restart it without restarting Service Desk.

Error message: Required environment variable NX_ATUS_CATALINA_BASE not found.

 

Environment:
ServiceDesk 12.x -14.x
Cause:

When running pdm_tomcat_nxd without a switch for example "-c or -d", it will gives the following error

Required environment variable NX_ATUS_CATALINA_BASE not found.

error1.JPG

 

Resolution:

When running the pdm_tomcat_nxd command to stop tomcat, start tomcat, or get status of tomcat please use the switch "-c or -d"

resolution1.JPG

Additional Information:

Here are more information regarding pdm_tomcat_nxd:

more_infor.JPG

Please click on the following link for more pdm_tomcat_nxd information

Please also note that the error message "Required environment variable NX_ATUS_CATALINA_BASE not found." may also show if the server names are incorrect as well