null values in the custom Ad Hoc report

Document ID : KB000122513
Last Modified Date : 06/12/2018
Show Technical Document Details
Issue:
There are null value in the Ad Hoc report
The srmdbapi.v_fact_alarm_info table has null values. 
The reporting.alarminfo table has the same issue, null values.

mysql> select * from alarminfo where alarm_key=161063\G 
*************************** 1. row *************************** 
alarm_key: 161063 
alarm_id: 5bf31987-93fd-1057-00f3-800005002da9 
landscape_h: 1048576 
model_h: 1074516 
orig_event_key: 25819103 
orig_event_type: 67329 
condition_id: 1 
cause: 8523777 
set_time: 2018-11-19 18:13:59 
clear_time: 2018-11-20 11:13:22 
clear_user: NULL 
clear_user_key: 1 
alarm_title_id: 44010 
model_key: 83426 
persistent: 1 
impact_severity: 0 
ack_time: NULL 
ack_user_key: NULL 
first_assigned_time: NULL 
first_assigned_user_key: NULL 
first_assigning_user_key: NULL 
last_assigned_time: NULL 
last_assigned_user_key: NULL 
last_assigning_user_key: NULL 
set_troubleticket_time: NULL 
set_troubleticket_user_key: NULL 
set_troubleticket_id: NULL 
 
Environment:
CA Spectrum 10.x
Cause:
Someone has customized the 0x10707 code to disable storing the event into the DDMdb database. 
 
Resolution:
Enabled back the "Store Event in Historical Database" for the 0x10707 even code.