Null pointer exception on Service Desk integration configuration page with Spectrum 9.3 (non-English versions) and EEM.

Document ID : KB000019012
Last Modified Date : 14/02/2018
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Description:

Null pointer exception on Service Desk integration configuration page with Spectrum 9.3 (Non-English versions) and EEM, this can occur if you are setting up the integration or making any changes to an existing integration for Service Desk.

When CA Spectrum 9.3 (Non-English versions) is being integrated with Service Desk a Null Pointer Exception can occur.

If using a Japanese OS, for example, the error message will look similar to this:

HTTPステータス 500 - java.lang.NullPointerException

--------------------------------------------------------------------------------

type 例外レポート

メッセージ java.lang.NullPointerException説明 The server encountered an internal error that prevented it from fulfilling this request.例外 org.apache.jasper.JasperException: java.lang.NullPointerException

org.apache.jasper.servlet.JspServletWrapper.handleJspException(JspServletWrapper.java:549)

org.apache.jasper.servlet.JspServletWrapper.service(JspServletWrapper.java:470)

org.apache.jasper.servlet.JspServlet.serviceJspFile(JspServlet.java:390)

org.apache.jasper.servlet.JspServlet.service(JspServlet.java:334)

javax.servlet.http.HttpServlet.service(HttpServlet.java:728)

org.apache.struts.action.ActionServlet.processActionForward(ActionServlet.java:1759)

org.apache.struts.action.ActionServlet.process(ActionServlet.java:1596)

org.apache.struts.action.ActionServlet.doPost(ActionServlet.java:510)

javax.servlet.http.HttpServlet.service(HttpServlet.java:647)

javax.servlet.http.HttpServlet.service(HttpServlet.java:728)

原因

java.lang.NullPointerException

com.aprisma.util.resource.LocaleStringKey.hashCode(LocaleStringKey.java:87)

java.util.HashMap.hash(HashMap.java:351)

java.util.HashMap.getEntry(HashMap.java:443)

java.util.HashMap.get(HashMap.java:405)

com.aprisma.util.resource.ResourceManagerBase.getMessageFormatInternal(ResourceManagerBase.java:390)

com.aprisma.util.resource.ResourceManagerLocal.getMessageFormat(ResourceManagerLocal.java:106)

com.aprisma.util.resource.ResourceManagerLocal.formatString(ResourceManagerLocal.java:136)

com.aprisma.util.resource.ResourceManager.formatString(ResourceManager.java:278)

com.aprisma.spectrum.app.web.taglib.ApMessagesTag.doStartTag(ApMessagesTag.java:181)

org.apache.jsp.WEB_002dINF.svdsk.service_002ddesk_002dconfig_jsp._jspService(service_002ddesk_002dconfig_jsp.java:608)

org.apache.jasper.runtime.HttpJspBase.service(HttpJspBase.java:70)

javax.servlet.http.HttpServlet.service(HttpServlet.java:728)

org.apache.jasper.servlet.JspServletWrapper.service(JspServletWrapper.java:432)

org.apache.jasper.servlet.JspServlet.serviceJspFile(JspServlet.java:390)

org.apache.jasper.servlet.JspServlet.service(JspServlet.java:334)

javax.servlet.http.HttpServlet.service(HttpServlet.java:728)

org.apache.struts.action.ActionServlet.processActionForward(ActionServlet.java:1759)

org.apache.struts.action.ActionServlet.process(ActionServlet.java:1596)

org.apache.struts.action.ActionServlet.doPost(ActionServlet.java:510)

javax.servlet.http.HttpServlet.service(HttpServlet.java:647)

javax.servlet.http.HttpServlet.service(HttpServlet.java:728)

注意 原因のすべてのスタックトレースは、Apache Tomcat/7.0.40のログに記録されています

Solution:

While integrating Service Desk with CA Spectrum 9.3 (non-English version), or while updating any configuration on Service Desk integration page in OneClick Administration, if EEM is already integrated, the workaround is to remove EEM integration and perform Service Desk Integration or do any changes to already existing Service Desk Integration.

User should not see the Null pointer exception. Now user can re-integrate EEM with CA Spectrum 9.3.