nsdgtw probe proxy settings for monitoring CA (Nimsoft) Service Desk a.k.a. ServiceAide

Document ID : KB000125653
Last Modified Date : 04/02/2019
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Issue:
The nsdgtw probe help doc mentions proxy setting options only available in nsdgtw probe v1.23 via the Admin Console ONLY. But they are NOT displayed in the Admin Console nor within IM via the probe GUI and we can’t find any such option.
Environment:
- UIM v8.5.1
- nsdgtw probe v1.23 or higher
Cause:
- nsdgtw proxy settings must be configured using Raw Configure
- proxy settings must be enabled in the probe and configured properly
Resolution:
nsdgtw v1.23

In the <setup> section of the nsdgtw probe configuration file (nsdgtw.cfg), please add the following new keys:

is_proxy_settings = yes
proxy_domain =
proxy_host =
proxy_name =
proxy_port = 0
proxy_user =
proxy_pass =

Configure them with the correct values and click Ok.

Then Deactivate->Activate the probe.

Check the nsdgtw.log

Test the connection and check if the nsdgtw can connect via the proxy. and check if tickets are being generated.

Note that these settings do not get exposed/displayed in the Admin Console.

The customer resolved the nsdgtw probe connection problem where the Server URL, Username and Password to CA (Nimsoft) Service Desk, a.k.a. "ServiceAide" was already configured properly, with the following proxy settings (modified for privacy/confidentiality):

is_proxy_settings = yes
proxy_domain = abchosting.net
proxy_host = xyz1proxy
proxy_name - xyz1proxy.abchosting.net
proxy_port = 8080
proxy_user = uim.service
proxy_pass = *********

 
Additional Information:
Note that the sdgtw probe can also be used for CA (Nimsoft) Service Desk (ServiceAide)
https://docops.ca.com/ca-unified-infrastructure-management-probes/ga/en/alphabetical-probe-articles/sdgtw-service-desk-gateway/sdgtw-ac-configuration#sdgtwACConfiguration-ServiceAide